Jump to content

mark.wheeler@iag.com.au

Members
  • Content Count

    22
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mark.wheeler@iag.com.au

  • Rank
    Level 2 Contributor
  1. Thanks Mitu. It doesn't work unless I prefix propFormName with "windows." as follows: if (window.propFormName == "list_pr.htmpl" && menuName == "idDetailsMenu" && itemName == "Research...") return "Current Update..."; I'd like to do the same thing for Activities --> Research... in detail_pr.htmpl. I tried using the same code in function siteMenuitemMod(menuName, itemName) but it doesn't work. I then tried doing the mod in menubar_sd.htmpl but I can't make it any more granular than factory = 'cr' because it doesn't recognise factory = 'pr'. Any ideas?
  2. Hi, Our system is r12.1 with cumulative patch #2 (RO12848 and RO12850) and RO11972. My requirement is to rename the "Research..." activity to "Current Update..." in the context menu for list_pr.htmpl. The context menu I'm referring to is the list of activities that appear when you hover over a problem ref num in list_pr.htmpl. I've used the following code in sitemods.js but it renames the activity in search lists for all ticket types. How can I rename it for list_pr.htmpl only? function siteContextMenuitemMod(menuName, itemName) { if (menuName == "idDetailsMenu" && itemName == "Research...") return "Current Update..."; } Fyi, the usage of this function is documented in F:\Apps\CA\Unicenter ServicePlus Service Desk\sdk\scripts\sitemods.js Thanks
  3. Has anyone been able to successfully use role id in spel. We have some requirements which need to be differentiated by the analysts role in 12.1
  4. Thanks for all your help. This has been resolved. The reason for it not working is that the field z_created_group_id is also being populated by a post validate trigger and the order was not correct.
  5. Hi Guys Maybe I asked the wrong question. How do you know to use '6' or '3' ? Is there a definition of what each index of msg contains? Is the comparison of zreportedbygroupid == "DA6554CB9B6FA14F87A671472502009A" correct? You asked me to cast msg[6] to a string, but is putting the uuid as hex in quotes the correct syntax? The datatype of a contact's uuid in the database is "binary(16)", ie not a string. when doing (string)msg[6], is this binary value being converted to Hex string? or something else?
  6. Thanks Mikelm, Yes this is SREL to the contact. When using your code, it gives us a ticket UPGRD123456, even when the reported group is DA6554CB9B6FA14F87A671472502009A. We are trying to identify what "msg[6];" is, is this defined anywhere?
  7. Hi all been trying to use the WIKI for adding prefix to the ref_num Separate Prefixes for Requests, Incidents, and Problems Instead of using type to distinguish this we are using a custom field z_created_by_group_id which uses a UUID. The code we are using is below. CODEcr::zcrprefix(...) { string str_ref, zreportedbygroupid, zref_num; send_wait( 0, this, "get_attr_vals",2,"ref_num","z_created_group_id"); zref_num = msg[3]; zreportedbygroupid = msg[6]; //Replace the I P R below if you want different prefixes if ( zreportedbygroupid == "cnt:DA6554CB9B6FA14F87A671472502009A" ) { str_ref = format("CGU%s", zref_num); } else if ( zreportedbygroupid != "cnt:DA6554CB9B6FA14F87A671472502009A" ) { str_ref = format("UPGRD%s", zref_num); } else str_ref = format ("%s",msg[6]) + format("test%s", zref_num); send_wait(0, this, "call_attr", "ref_num", "set_val", str_ref, "SURE_SET"); The following code executes without error, but only ever runs the Else condition of the code. The If and Else If lines are not working, I believe that we are incorrectly referencing the UUID
  8. Hi All Wanting to know if anyone has tried to and had success with making contacts public for multi tenancy use. We are looking to use multi tenancy, our situation is that we have multiple service desks wishing to share contacts. Thanks in advance
  9. Was wondering if anyone has been able to partition Knowledge access by Access type ie we would like to stop our employees from viewing technical documents. I know we can do this by groups, however this does not assist in this instance.
  10. Still no luck after recycling services and server. Have logged an issue with CA and they have not found a solution.
  11. Sorry Mitu, should have explained, I have have full admin access with no security restrictions. I am sending the email to maileater and as administrator should have no issues. My access is exactly the same as our DEV envirinment in which this works. our email address are name@company.com.au (you@yourcompany.com was just an example email address)
  12. Have set up maileater in our DEV environment, works perfect after a few niggling issues. Finally put it into PROD and we get: AHD58045: Because of security restrictions, you are not allowed to complete this operation. Ask your security administrator for access. Cannot continue processing! Now I know this has been mentioned before in earlier threads, but as far as I can tell, it is not being caused by duplicate email address's. the error in the stdlog is: User (you@yourcompany.com) not authorized to modify factory (cr) The email address was because I tried -m you@yourcompany.com, but we get the same msg when I or my colleague send the email. I am at a loss as to the cause of this. Please help.
  13. Hi AKM. I have recreated doing a transfer with same result, refer attached. Cheers Wheels Transfer_assignee.doc
  14. This appears to work out of the box for us, so not sure what is different at our site. We are using 11.2 after upgrading from 6 12 months ago. I have attached some screen shots to show you how it works I have checked our NX.env, Magic files and can find nothing on how this works. Not sure why it does not work at other sites. Assignee.doc
  15. I think the above is a red herring, I think we still have an issue with a customised field z_caller_id. We have added this into the text_api.cfg in the KEYWORDS using the following: REQUEST.z_caller_id=z_caller_id.UUID.lookup_cnt_by_last_first_middle Then in the EMAIL_DEFAULTS added: REQUEST.z_caller_id=wheeler, mark I have even tried adding most of the information as defaults REQUEST.PRIORITY=2 REQUEST.CATEGORY=BAU Activity.Support Services REQUEST.IMPACT=Low REQUEST.Urgency=Low REQUEST.Type=R REQUEST.GROUP=USD_ADMIN And the format the email with just the Summary: Request And then in the email %Description=Test I keep on getting same error email: AHD58009: Could not create Request. Reason: INVALID - AHD03075: Required attribute is missing. (attribute: z_caller_id object: cr)
×
×
  • Create New...