Jump to content
Sign in to follow this  
Shak_78

Resolved: iTechnology iGateway 4.2 not starting up successfully

Recommended Posts

HI,

We are using CASD R11.2 with cum#2 patch. CASD is pointing to EIAM 1.8 and the EIAM is pointed to an external LDAS (sun)

For some reason our users and analysts are unable to logon to CASD since this morning. It turns out that the iTechnology iGateway 4.2 is not starting successfully.

When restarting the service it come up with an error of:

Could not start the iTechnology iGateway 4. on Local Computer. Error: 1053 the service did not respond to the start or control request in timely fashion

Then the service just hangs with starting status.

I have opened a ticket with CA, who are currently investigating the issue. But thought to post it here as some of you may have come across this issue or have an idea as to what could be causing it.

Any advise/suggestions will be greatly appreciated

Share this post


Link to post
Share on other sites

uninstall and let pdm_configure re-install eiam

1.stop all EIAM and it's related services

________________________________________________________

eTrust Directory - iTechPoz-XXXXXXXXX

eTrust Directory - iTechPoz-router

eTrust Directory ADministration Daemon - master

eTrust Directory SSL daemon - iTechPoz-server

iTechnology iGateway 4.0

Ingres Intelligent Database [ET]

________________________________________________________

make sure they are not running on the proceses manager

2.EIAM Uninstall process

Then try to Uninstall iTechnology iGateway 4.0 from the add/remove wizard

if it tells you to delete iPoz.conf and EIAM.cong spin.conf go to step B, if it successfully uninstalls then go to step C

(step B) go to your i-gateway directory in "F:\Program Files\CA\SharedComponents\iTechnology"

and delete iPoz.conf

and EIAM.cong

and spin.conf

(step C) and then Uninstall "eTrust Embedded Identity and Access Management"

simply click ‘Ok’ on all the funny errors.

Congratulations You have successfully removed EIAM

3.Removing Old files left over from the last EIAM installation.

Delete or Rename old folders

________________________________________________________

F:\Program Files\CA\SharedComponents\Embedded IAM

F:\Program Files\CA\SharedComponents\iTechnology

F:\Program Files\CA\eTrust Directory

F:\Program Files\CA\Advantage Ingres [ET]

________________________________________________________

and then re-run SD configuration to re-install EIAM

this has always worked for me regardless of the release

Share this post


Link to post
Share on other sites

Thanks Danegrey for you detailed reply.

This issue has just been resolved by CA. Their EIAM specialist managed to identify the cause of the issue.

The issue was that the ITM client spindle was failing...

Basically in the spin.conf file the following entries exist:

CODE
<Spindle Prefix="" Directory="" Spar="baseSpindle.spar" Description="SPIN Administration">baseSpindle</Spindle>

<Spindle Prefix="/ITMClient" Directory="" Spar="ITMClient.spar" Description="ITMClient" Version="8.1" Config="">ITMClient</Spindle>

<Spindle Prefix="/eiam" Directory="" Description="Embedded IAM Interface" Spar="eiamSpindle.spar">eiamSpindle</Spindle>

From what I understood when you start up the iTechnology iGateway it tries to process these spindles in order.. Due to an issue with the ITM Client (middle line) it kept on hanging at this stage and couldn't progress on to the last line which is for the EIAM.

So what they did was to remove the middle line and now it works fine...

I suspect the issue was caused by an updates to the ITM but not 100% sure...

Anyway thanks again for the info, I am sure it will come very useful in the future.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×