Jump to content
Sign in to follow this  
rami.abbas

Attachment Inquiry

Recommended Posts

Dears !

One of our clients attached an excel sheet with the format: filename.xlsx

When i tried to open that file, it seems like a zipped file. When I tried to open it, it was containing a lot of xml files and i couldn't find\open the excel sheet itself.

This happened whenever we attach a file with the new MS office formats only!

Any clue fellows?

Thanks in advance.

Have a great day all..

Best regards,

Rami

Share this post


Link to post
Share on other sites

Yes, it's supported. You just have to add the document MIME type to the Tomcat's extension list. There is a techdoc on the CA site that shows how to do this, you can use that to get the MIME types from there. The document incorrectly states that you need to add the types to the IIS Admin, in reality the attachments are downloaded from Tomcat and you need to add it there, I think the correct file is $NXROOT\bopcfg\www\CATALINA_BASE\webapps\CAisd\WEB-INF\web.xml, at the end of the file (look for the mime-mapping stanzas).

Edited by Mitu

Share this post


Link to post
Share on other sites

Hello Rami,

You can add the Offide 2007 Mime types to $NX_ROOT/bopcfg/www/CATALINA_BASE/webapps/CAisd/WEB-INF/web.xml as following.

CODE

<!-- ===================== Default MIME Type Mappings =================== -->

<!-- When serving static resources, Tomcat will automatically generate -->

<!-- a "Content-Type" header based on the resource's filename extension, -->

<!-- based on these mappings. Additional mappings can be added here (to -->

<!-- apply to all web applications), or in your own application's web.xml -->

<!-- deployment descriptor. -->

<mime-mapping>

<extension>docm</extension>

<mime-type>application/vnd.ms-word.document.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>docx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.wordprocessingml.document</mime-type>

</mime-mapping>

<mime-mapping>

<extension>dotm</extension>

<mime-type>application/vnd.ms-word.template.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>dotx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.wordprocessingml.template</mime-type>

</mime-mapping>

<mime-mapping>

<extension>potm</extension>

<mime-type>application/vnd.ms-powerpoint.template.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>potx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.presentationml.template</mime-type>

</mime-mapping>

<mime-mapping>

<extension>ppam</extension>

<mime-type>application/vnd.ms-powerpoint.addin.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>ppsm</extension>

<mime-type>application/vnd.ms-powerpoint.slideshow.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>ppsx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.presentationml.slideshow</mime-type>

</mime-mapping>

<mime-mapping>

<extension>pptm</extension>

<mime-type>application/vnd.ms-powerpoint.presentation.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>pptx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.presentationml.presentation</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xlam</extension>

<mime-type>application/vnd.ms-excel.addin.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xlsb</extension>

<mime-type>application/vnd.ms-excel.sheet.binary.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xlsm</extension>

<mime-type>application/vnd.ms-excel.sheet.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xlsx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.spreadsheetml.sheet</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xltm</extension>

<mime-type>application/vnd.ms-excel.template.macroEnabled.12</mime-type>

</mime-mapping>

<mime-mapping>

<extension>xltx</extension>

<mime-type>application/vnd.openxmlformats-officedocument.spreadsheetml.template</mime-type>

</mime-mapping>

Best Regards,

JM

Edited by Jose Manuel

Share this post


Link to post
Share on other sites

Another option you can try is to install the Microsoft Office compatibility pack on your local machine\PC. Remember that USD will always try to open the attachment with the application associated with the file.

So if you have a compatibility pack that allowes you to open MS Office 2007 files from an earlier MS Office version, then add the file extention to mimi-mappings as indicated by Rami and Mitu, you should be sorted.

Edited by N@irB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...