Jump to content
Cybero

Calling a web service when workflow task starts

Recommended Posts

Hi,

I'm trying to find the best way to call an external web service on a task
This web service controls the inputed fields of a change request and return ok or not
So the task is set to OK or not automatically

I created an  action macro that I assigned to a specfic status of a workflow task
So when the task starts, the macro is called ==> OK

But I don't know how to call a web service in the macro, or via spell code
Can"t find the way to do it

Could you guide me in the right way to do it ?

 

Thanks in advance

Regards

 

Oliver

Share this post


Link to post
Share on other sites

Hi,

 

Spell (spl) or sdm itself can't be used to call webservices. But perl can and also perl scripts can be called via spel_srvr as regualr spel methods. This way is fun and pleasant to implement.

Useful links:

Also there is a "legal" way using CA PAM but didn't tried it.

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites

Hi @cdtj

Thank you for answering me :D
I've been able to call perl via spel with the guide above 👍


But... but...  I did not find anything in the sdm perl package to make web service calls (REST)
Even simpliest ways are not possible (http & lwp based)
I also did not find how to easily add new packages to sdm 

<_<

So ... I created a VBS script that makes calls to the web service, called from the perl script, called from the spel method :wacko:
It worked but ... I'm not fully satisfied, all parameters must pass from spel to VBS and return from VBS to spel
Technical architecture does not please me at all

I'm pretty sure there's a cleaner way to do that 

 

On the mentioned site (Great Source !), I read in an example a call to a VBS script directly from the spel
This would avoid the "perl transition step"

But I have not been able to run the example, the declaration of the function in the mod file does not work (and crash SDM ouch)
Dunno what I'm doing wrong

 

Last but not least ... thanks to you, at the end of this day I have a working POC
Not perfect but working POC :wub:

Share this post


Link to post
Share on other sites

currently i'm out of business and cant test anything, but i'm pretty sure i called webservices using perl directly from sdm.

you can use cmd to debug perl scripts

pdm_perl <scriptname.pm>

and i think that perl libs/binaries should be somewhere near pdm_perl file

 

regarding that vbs example, it looks like bullshit (sorry), because:

  • method have dot in it's name which is restricted;
  • method declared without arguments and not even called within example, but it's passed as argument for .exe file which is not method name at all;
  • send_wait called method with .exe is trying to pass some arguments which are not declared

 

  • Like 1

Share this post


Link to post
Share on other sites

Ok so I forget the vbs example :lol:
 

I did not have time to work on this today 
Yesterday, I made my "Web service tests" with pdm_perl and was not able to include neither http nor lwp

Found the perl libs in... (not at office, and this forum is blocked by the proxy there :rolleyes:) something like

D:/PROGRA~1/CA/SERVIC~1/bin/perlib/5.12.2

pdm_perl is located in the bin folder above

I was asked few improvements on the POC, will (try to) work on it tomorow

If you have a web service call in perl file example... I would be intersted :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...