Jump to content
carlos.pires

Rest WebService authentication problem

Recommended Posts

Hello, I'm having problems authenticating to the rest ws. This is the log (spanish):

09/10 16:41:19.866 [http-bio-8050-exec-10] ERROR BasicAuthenticator 113 BPMessagingException error on authentication validation for userid(ServiceDesk). com.ca.sdm.bop.BPMessagingException: AHD04020:Error de inicio de sesión de userid (ServiceDesk) Error de inicio de sesión de userid (ServiceDesk);no se ha encontrado rol predeterminado para el tipo de sesión (10)

09/10 16:41:19.868 [http-bio-8050-exec-10] ERROR SecurityInInterceptor 324 Basic Authorization failed (Error de inicio de sesión de userid (ServiceDesk) Error de inicio de sesión de userid (ServiceDesk);no se ha encontrado rol predeterminado para el tipo de sesión (10))

It says that, there is no predifined role for the type of session.

Is there any specific role to activate or config that I should add?

Share this post


Link to post
Share on other sites

Check the Access Type of the user (ServiceDesk) and make sure that on the Roles tab there is a value on the 'Web Service Role' lookup.

Share this post


Link to post
Share on other sites

If the default SDM sample has problems, open an issue with CA Support and ask them to fix it - to provide with a correct sample.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...