Jump to content
Sign in to follow this  
PMXSD

Resolved: IDs in Custom Tables

Recommended Posts

Forum,

I have created a custom table and with that I did a list and detail form to fill information in Service Desk but also that table can be filled with a process in PAM. So, here I have an issue because when I add information with PAM process and then I try to add information in Service Desk also, I get an error saying that I violated Unique ID. So, I did a bit researching and I noticed that when I add information using the PAM's operator Insert in Database, the ID is not updated in Service Desk when I try to fill the information in Service Desk.

How can I manage the IDs in the custom table to avoid this issue?

I need this as soon as possible to deliver a development!

Thank you so much!

Share this post


Link to post
Share on other sites
Forum,

I have created a custom table and with that I did a list and detail form to fill information in Service Desk but also that table can be filled with a process in PAM. So, here I have an issue because when I add information with PAM process and then I try to add information in Service Desk also, I get an error saying that I violated Unique ID. So, I did a bit researching and I noticed that when I add information using the PAM's operator Insert in Database, the ID is not updated in Service Desk when I try to fill the information in Service Desk.

How can I manage the IDs in the custom table to avoid this issue?

You don't manage the IDs - let SDM do it for you. You shouldn't manipulate the DB directly because you're bypassing the SDM object layer - which should take care of generating/managing IDs - instead use the SDM operators to query/update/insert into the custom table.

Share this post


Link to post
Share on other sites
You don't manage the IDs - let SDM do it for you. You shouldn't manipulate the DB directly because you're bypassing the SDM object layer - which should take care of generating/managing IDs - instead use the SDM operators to query/update/insert into the custom table.

Thank you Mitu, but I don't see any operator to insert a new value for a custom table (just Select or Update but not Insert). It's that correct?

Please let me know!

Thanks!

Share this post


Link to post
Share on other sites

I don't know much about PAM's SDM operators, but I think they're based on SDM WebServices and the WS have a 'createObject' method that would allow you to create any SDM object. Or you can try the 'Update' operator to see if it inserts values for non-existent objects.

Edited by Mitu

Share this post


Link to post
Share on other sites
I don't know much about PAM's SDM operators, but I think they're based on SDM WebServices and the WS have a 'createObject' method that would allow you to create any SDM object. Or you can try the 'Update' operator to see if it inserts values for non-existent objects.

You're rock!! I used the operator to invoke Service Desk's Web Services and then applied the createObject method and that solved the issue and also I learned to use the web service! When I finish this development I will post this in the Service Desk Library.

Thank you very much Mitu

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...